PDA

View Full Version : MessageLabs


prav
07-16-2008, 02:42 PM
Hi,

Anybody having trouble sending emails to recipients who are looked after by MessageLabs?

Each time I send them an email from the Axigen software, the MessageLabs server gives me a 421 Service Temporarily Unavailable error message.

I can send emails manually from the mail server using netcat with no trouble so there are no issues with my mail server being blacklisted. Only thing I can think of is that the Axigen Mail server is not fully compliant with RFC821.

Any comments?

Cheers,
Prav.

prav
07-17-2008, 07:25 AM
Attached is a packet capture for a test email to a domain looked after by MessageLabs ....

adi
07-17-2008, 08:31 AM
Hello,

In order to analyze this problem, please follow these steps:
- set the maximum log level under 'Services' -> 'SMTP Sending' in Axigen's Webadmin
- replicate the problem
- attach the restulting Axigen log file (usually /var/opt/axigen/log/everything.txt)

Including a transcript of the netcat SMTP session may also be useful.

Best regards,

prav
07-19-2008, 09:04 AM
Hi,

Here is the everything.txt file with full logging enabled. The email domains I am having trouble with are bestinvest.co.uk and deloitte.co.uk.

prav
07-21-2008, 07:10 AM
Hi,

Here is the everything.txt file in full logging mode. The domains I am having trouble with are bestinvest.co.uk, and deloitte.co.uk.

Here is my manual attempt with netcat which goes through fine (this was also done from the same mail server):

root@mx:~# nc -vv cluster2.eu.messagelabs.com 25
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail83.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail71.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail72.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail114.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail115.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail133.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail78.messagelabs.com
DNS fwd/rev mismatch: cluster2.eu.messagelabs.com != mail80.messagelabs.com
cluster2.eu.messagelabs.com [195.245.231.83] 25 (smtp) open
220 server-11.tower-83.messagelabs.com ESMTP
ehlo localhost
250-server-11.tower-83.messagelabs.com
250-STARTTLS
250-PIPELINING
250 8BITMIME
mail from: <prav@darklabs.co.uk>
250 OK
rcpt to: <craithatha@deloitte.co.uk>
250 OK
data
354 go ahead
From: prav@darklabs.co.uk
To: craithatha@deloitte.co.uk
Subject: Test Message
Hello Chet,

Having a bit of trouble with sending you email. This one was sent hand cranked. Let me knoe if you receive it.

Cheers,
Prav.
.
250 ok 1216219135 qp 32005 server-11.tower-83.messagelabs.com!1216219030!46499647!1
quit
221 server-11.tower-83.messagelabs.com
sent 342, rcvd 313


Any feedback would be much appreciated.

Cheers,
Prav

marius
07-21-2008, 09:42 AM
Hello,

It appears that the everything.txt log file attached did not contain any references to SMTP-Out connections. These details should provide all communication details with the remote server.

If you have a special logging policy for the SMTP Sending module, you should also attach us the corresponding file that contains these entries.


We are waiting for a feedback on this matter.

prav
07-22-2008, 06:01 PM
Hi,

I do not have any special policy settings for logging. I have set SMTP Sending under Services to log "Protocol Communications" and to use the System log. I can see the axigen server attempt to relay the mail to the bestinvest.co.uk domain but never succeeding. I have included the error information from the Queue log for the failed message:

Fail-info: Service Temporarily Unavailable
Status:PROCESSED - RELAY
MBox:INBOX

Please also review the pcap file I provided earlier with Wireshark to view the actual protocol communications.

I have also attached a screenshot of my log settings for smtp sending in case I am doing something wrong there.

marius
07-25-2008, 03:12 PM
Hello again,

You should reset the log type for the SMTP Sending service to Internal as to preserve this data into the everything.txt file. This data can be used as a reference with the pcap file previously attached.

prav
07-30-2008, 07:33 AM
Hi,

I have changed the log to internal and the everything.txt file now includes a number of smtp-out messages. I've attached the file for your reference.

Thanks,
Prav.

dani
07-30-2008, 08:32 AM
Hello,


It looks like the remote server is returning a "421 Service Temporarily Unavailable" message and rejects the message.
07-30 08:29:06 +0100 16 mx SMTP-OUT:00000171: << 421 Service Temporarily Unavailable
07-30 08:29:06 +0100 08 mx SMTP-OUT:00000171: RCPT recipient(@)domain rejected with message: Service Temporarily Unavailable
07-30 08:29:06 +0100 08 mx SMTP-OUT:00000171: No RCPT accepted for mail 1547AB; aborting transaction
07-30 08:29:06 +0100 08 mx SMTP-OUT:00000171: Disconnected from 216.82.248.45

Please make sure that the recipient of your message can properly receive messages perhaps from another mail server. However you should contact the remote server's administrators to find more information regarding the rejection message.

prav
07-30-2008, 01:41 PM
Hi,

As stated earlier in the post, I can successfully email the recipient from any other email system (hotmail, gmail, ISP mail server, I can even send an email using netcat!). The only system that appears to fail is Axigen. Please advise.

Thanks,
Prav.

mihai
07-31-2008, 01:50 AM
Hello,

It seems that all MX servers from MessageLabs rejects AXIGEN connections when sending the EHLO command, except the last MX server who accepts your EHLO but rejects the email transaction with 421 Service Temporarily Unavailable.

In order to get your connections accepted by the recipient MX servers, you need to use your FQDN instead of "mx" in the EHLO text for outgoing connections. You can find information on how to change it in the KB article from this link (http://www.axigen.com/knowledgebase/How-to-setup-AXIGEN-5-0-to-use-a-specified-FQDN-when-sending-emails-modify-the-default-SMTP-banner-for-incoming-connections_128.html).

For testing purposes you can trace AXIGEN's steps from the log file, connect to the MX records AXIGEN tried to connect, using telnet or netcat, and send an "EHLO mx" command.

Regards,

prav
07-31-2008, 03:48 PM
That worked! Thanks for the help.

Cheers,
Prav.