Community

Blank page when accessing webmail using Docker

Hi,

I’ve been more or less digging up and down any results that google has been able to provide me with. WebAdmin works flawlessly and I’ve tried to change the ports for the webmail but to no effect. I’ve also updated from Axigen 10.2.2 to Axigen 10.2.2.84

Current config:
https://www.codepile.net/pile/QE4g2a3J
Operating system: Linux / x64
Current Server version: 10.2.2
Current WebMail version: 10.2.2
Current WebAdmin version: 10.2.2

Webmail:

Could anyone point me in the right direction?

Hi
At first please keep your axigen with the latest updates.
Than you can change webmail port by logging in “webadmin > services > webmail listeners”
But please note that you need to make change firewall of operating system to allow your selected port.

Hello,

Let’s see what containers are running on your host, thus please share with us the output of the following command (from your host):

docker ps -a

Please advice,
Ioan

Hi Mohammad,

As stated in the text I’ve both updated from 10.2.2 to 10.2.2.84 and changed the ports but to no avail

Hi Ioan,

docker ps -a

CONTAINER ID 61af93a746a5
IMAGE axigen/axigen
COMMAND “/bin/sh -c /app/run…”
CREATED 41 hours ago
STATUS Up 16 hours
PORTS 80/tcp, 110/tcp, 0.0.0.0:25->25/tcp, 0.0.0.0:443->443/tcp, 0.0.0.0:465->465/tcp, 0.0.0.0:993->993/tcp, 0.0.0.0:995->995/tcp, 143/tcp, 0.0.0.0:7000->7000/tcp, 0.0.0.0:9000->9000/tcp, 0.0.0.0:9443->9443/tcp, 8443/tcp
NAMES axigen

Hello,

1/ Please try with same browser but in incognito mode

2/ Please try to another browser (like Chrome)

3/ Please share the output from the following command (from your host)

curl https://localhost:443

Please advice.

Best regards,
Ioan

curl : The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
At line:1 char:1

  • curl https://localhost:443
  •   + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebException
      + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
    
    

curl : The underlying connection was closed: The connection was closed unexpectedly.
At line:1 char:1

  • curl http://localhost:443
  •   + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebException
      + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
    
    

Same browser but incognito - same results

Chrome - Access to localhost was denied

You don’t have authorization to view this page.

HTTP ERROR 403

It has been solved, I found VmWare Workstation listening on port 443 which caused the error. When uninstalling VmWare Workstation this worked flawlessly

2 Likes