Community

Let's Encrypt Acmev1 issue

Trying to configure a cert in a fresh install with lets encrypt, but get an error response from lets encrypt due to ACMEv1 being disabled and needing to move to ACMEv2. In the response there is a link explaining it.
Is there a way to get a certificate from lets encrypt using ACMEv2

2019-11-21 00:00:58 +0000 08 ip-10-201-0-81 JOBLOG:70000003: LetsE: Acme job executing
2019-11-21 00:00:58 +0000 08 ip-10-201-0-81 JOBLOG:70000003: LetsE: AcmeInitState for xxxxxxxx executing
2019-11-21 00:00:58 +0000 08 ip-10-201-0-81 JOBLOG:70000003: LetsE: Response code 403
2019-11-21 00:00:58 +0000 02 ip-10-201-0-81 JOBLOG:70000003: LetsE: Issuance Job for xxxxxxxx abandoned!
2019-11-21 00:00:58 +0000 02 ip-10-201-0-81 JOBLOG:70000003: LetsE: last protocol errType urn:acme:error:unauthorized
2019-11-21 00:00:58 +0000 02 ip-10-201-0-81 JOBLOG:70000003: LetsE: last protocol errDetail Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430 for details.
2019-11-21 00:00:58 +0000 02 ip-10-201-0-81 JOBLOG:70000003: LetsE: Job step action => Cannot complete current work item, abandoning

Hello,

Starting with Axigen 10.2.2.84 ACMEv2 client was included.

My recommendation is to update you install (Binary and Web Interfaces) to the latest version available 10.2.2.86:

https://www.axigen.com/updates/axigen-10.2.2.86/

Regards,
Florin