Community

Same domain -can working on Axigen and gmail?

Hi,
My Name is julian . we have setup 30 user on Axigen and 30 users on gmail in same domain.
we have create catch-all account in gmail for incoming and outgoing and it is done for incoming but outgoing has not resolved
please help me .

Hi,

Thank you for your message.

In order to relay all messages for inexistent local users of <Your_Domain.COM> to another mail server (for example 10.10.10.10) holding different mail accounts of <Your_Domain.COM> also ,you may use the following steps:

  • from the Webadmin Interface go to Security & Filtering > Acceptance & Routing
  • go to the Advanced Settings TAB and click on +Add Acceptance / Routing Rule
  • under the Rule name text box enter a relevant name
  • in Conditions select from the combo box Recipient > Email is local click +Add Condition and do not tick the “is local” box
  • in Conditions select from the combo box Recipient > Domain click +Add Condition and in the text box next to: Recipient domain > is > enter your domain name <Your_Domain.COM>
  • make sure to select on “For incoming messages that match” the ALL of the conditions bellow option.
  • in the Actions section select from the combo box SMTP > Action > Click +Add Action and select the Accept option
  • in the Actions section select from the combo box Recipient > Recipient relay host click +Add Action and in the text box of it add your external server’s SMTP address (for example [10.10.10.10])
    Note: When you enter the IP address of your external SMTP server make sure to have it between branches [IP].
  • Click Save Configuration to save the rule.

Hi,

I am creating new rule on axigen server in Acceptance & Routing
now my external mail is working but when we send mail for gmail same domain user showing following error -An error occurred while sending mail. The mail server responded:
User not found.
please help me .

Hello,

Thank you for your response.

In order to have the rule working, please use the Axigen mail server’s IP as MX server.

Thank you.

Hi Maxim,

can you please explain? how to set Axigen mail server IP as MX server.

Hi,

I have created rule for the same as you mention. 1) when i select “ALL of the conditions below” option to sending mail from Axigen internal to gmail same domain users but that time i am not receiving any email
2) when i select “Any of the condition below” option then mail is received but But we can’t send mail
Below showing error
An error occurred while sending mail. The mail server responded:
User not found.
please solved this

Hi,

Please leave selected All of the conditions below.

Regarding the mentioned behavior when having this option set, please first of all confirm that the MX dns record is set to Axigen with the highest priority (lowest number) and if so, please attach to your response the SMTP-IN, PROCESSIGN and SMTP-OUT modules log file that cover such an event and also the smtpFilters.script file available at /var/opt/axigen/filters/smtpFilters.script for Linux or C:\Program Files\Axigen Mail Server\filters\smtpFilters.script for Windows.

Thank you.

Hi Maxim,

The problem you have in post #2 (User not found) is that axigen routing will look at the domain name of the recipient and identify it as belonging to that server and try and resolve the user locally instead of sending the message out externally to gmail. And so you get the user not found error because that user is on gmail not axigen.

You need to intercept them.
Under Security & Filtering/Acceptance & Routing/Advanced Settings:

Set up a “Relay to External” rule that match “ANY of the conditions below” and then add a line for each user:
“Recipient email is user1 @ gmail.com

Under Actions you need an external smtp server - try a gmail one - I’m not sure how that will pan out security wise.

I had a similar problem: common domain with some users hosted by an ISP and some on axigen. I solved it the other way by having the myuser @ domain1 .com MX record pointing at the ISP hosting email server with forwarders set up on that server for the axigen users which then forwarded to the axigen server.

The axigen server was set up on a completely different domain domain2 .com. So the ISP forwarders would forward to myuser @ domain2 . com.

Now:

In axigen I set up an email domain the same as the 1st (domain1 . com) and set an alias for that domain as domain2 . com so that users would receive email sent to both domain addresses.

You need the intercept rule I described above so that mail for domain1 . com users NOT hosted by axigen gets sent off the axigen box rather than being resolved locally and failing.

Regards,
Andy.