Community

Unable to add IP

Hi i am using axigen version 10 on AWS linux AMI, I am trying to add one AWS ip in smtp recieving tab i.e. 52.14.119.255

image

tried to add by using subnet mask but still same.

any way to add this IP?

Hello ,

The IP addresses could be added in Axigen interface only if them are present (to be read configured) on the server.

On up to date Linux installations you could obtain the list of configured IP addresses with the following command:

ip a | grep inet | awk '{print $1,$2}'

Because on AWS the external IP addresses (also known as Elastic IP) are not configured on the server (but on your account and attached to a private one) you could not configure in Axigen a listener with such IP addresses (the “elastic” ones).

My recommendation is to use the generic 0.0.0.0 address that means that you will have a listener on all IPv4 addresses present on the machine. Note: the corresponding generic IPv6 address is ::

If you like to set only to the private address that is configured in AWS for the elastic one than you have to identify and use in Axigen the local IP address that is corresponding to the external IP address that you like to use.

HTH,
Ioan

Hi,
There are already multiple IP’s(elastic IP’s) added, issue is only with this specific IP.
you can try it by using it to your own axigen server, please check snapshot below,
We can not allow 0.0.0.0 beacuse we are using restricted environment.

Hello,

Sorry but I’ve wrongly understand your problem.

So you like to add one access rule for a specific IP address and the operation failed saying that the “provided IP is not valid”.

The problem is that we are not accepting IP addresses ending with 0 or 255 due to a (too) simple WebAdmin rule that is trying to prevent adding “network” or “broadcast” IP addresses.

A workaround exists and basically all you have to do is to create the rule from WebAdmin (using .254 instead of .255), stop Axigen service, edit the rule from axigen.cfg (changing .254 to .255) and starting the service afterwards.

Note: I’ll report this issue internally and we may fix it but most probably in one of the future releases so you may be interested in applying the workaround mentioned above instead of waiting for a fix.

Please let us know if you need more information on this matter.

BR,
Ioan

okay thanks for the soultion i followed the same method and it worked well, now i have to add the same ip in message routing settings, how can i add it here.

Hello,

Please apply the same workaround mentioned above but, instead of correcting the IP address in run/axigen.cfg made the needed change in filters/smtpFilters.script (hint: you should find the IP under a method like WA_Routing_basic_relay_from_X).

HTH,
Ioan

its worked well.
thanks

I had a similar problem where I wasn’t able to add the IP addresses but I just reset everything and started from scratch (I was testing) and somehow it magically worked for me. definitely not something you can do for a real project but I think it was worth sharing.