• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Upgraded to 10.1 and lost the Axigen service

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgraded to 10.1 and lost the Axigen service

    Hi I just upgraded from 10 to 10.1 on Windows. I just ran the install overtop of my existing installation. Everything seemed to go fine, only problem is the Axigen service has disappeared so for now I'm manually running the .exe to get the server going. Is there an easy way to re-install the Axigen service?

    Thanks,
    Todd

  • #2
    Hello,

    Please open the registry editor and share with us what you have at this location: HKLM \ System \ CurrentXControlSet \ Services \ Axigen

    You may open a terminal (as administrator) and run the following command to register the Axigen service:
    Code:
    axigen --install
    HTH,
    Ioan

    Comment


    • #3
      Thank you! There was no Axigen entry in HKLM \ System \ CurrentXControlSet \ Services. So I ran the command you mentioned and that created the service/registry entry. Everything seems to be fine now. Thanks again.

      Todd

      Comment


      • #4
        Hi,

        I have the same issue running Axigen on Amazon in a micro instance with 1GB RAM.
        Axigen 10 works fine, but when I upgrade to 10.1 I get the following:

        C:\Program Files\Axigen Mail Server\bin>axigen --install
        Not enough available memory: 215MB (min=512MB required)

        Is there no way for me to upgrade to 10.1?
        I won't upgrade to a bigger Amazon instance as this would be too expensive for me.
        I have just me and my kids as users (4 users in total), so it's running as cheap as possible.

        Thanks
        Last edited by MatythiasAussi; 03-27-2017, 01:53 PM.

        Comment


        • #5
          Hello,

          My advice is to continue using 10.0 as most probably you will not miss any new features from 10.1.

          Nevertheless you could try:
          • adding '-m 0' to the command line (for service install and later, for service starting command)
          • migrating to Linux
          HTH,
          Ioan

          Comment


          • #6
            Originally posted by indreias View Post
            Nevertheless you could try:
            • adding '-m 0' to the command line (for service install and later, for service starting command)
            Thanks, I was able to install the service and start Axigen manual, but adding -m 0 to the service start up command did not work (via registry editor). The service starts but stopps straight away.
            Can you please let me know how I can configure the service so it runs?
            P.s. at t he moment I'm running Axigen out of the command line on my server, so would be great to get the service up and running. ;-)

            Comment


            • #7
              Hello,

              Please follow the procedure listed below:

              1. Stop Axigen service and configure it to have Startup type = Manually


              2. Configure -m 0 in registry
              As administrator open regedit and modify the following key:

              HKLM \ System \ CurrentControlSet \ Services \ Axigen \ ImagePath

              from

              C:\Program Files\Axigen Mail Server\bin\axigen.exe

              to

              "C:\Program Files\Axigen Mail Server\bin\axigen.exe" -m 0


              3. Check if the above configuration was successfully saved by running the following command (from a terminal opened as administrator):
              Code:
              C:\WINDOWS\system32>sc qc axigen
              [SC] QueryServiceConfig SUCCESS
              
              SERVICE_NAME: axigen
                      TYPE               : 10  WIN32_OWN_PROCESS
                      START_TYPE         : 3   DEMAND_START
                      ERROR_CONTROL      : 1   NORMAL
                      BINARY_PATH_NAME   : "C:\Program Files\Axigen Mail Server\bin\axigen.exe" -m 0
                      LOAD_ORDER_GROUP   :
                      TAG                : 0
                      DISPLAY_NAME       : Axigen Mail Server
                      DEPENDENCIES       :
                      SERVICE_START_NAME : LocalSystem
              You should see that the BINARY_PATH_NAME string contains now -m 0


              4. Configure -m 0 in the AxiMonitor program
              Please start the axiMonitor.exe program from C:\Program Files\Axigen Mail Server\bin
              Afterwards, right-click on the corresponding icon from the system tray, select Options, enable the first checkbox (Register Axigen icon at system startup) to launch AxiMonitor at startup, and for the Axigen service startup parameters use: -m 0

              Note that changing the startup parameters only takes effect when the Axigen service is restarted though the AxiMonitor icon in the system tray. All further service actions (stop / start / restart) should be made from AxiMonitor instead from the usual Services panel.

              After you made all these changes and start the Axigen service from AxiMonitor you could use Process Explorer (started as administrator) and check that both Axigen processes (axigen.exe) have -m 0 into their Command line string.


              HTH,
              Ioan
              Last edited by indreias; 04-11-2017, 01:38 PM.

              Comment


              • #8
                Hi Ioan,

                thank you so much for your quick reply and all the details.
                I have followed all your steps and can now see the -m 0 for both Axigen processes in Process Explorer.
                But I have re-started the server and Axigen does not come up automatically any more.
                Only when I log in to the server and Manually start the Axigen Monitoring Agent.
                Is there any way I can get the automatic start at system start again?

                Many thanks,

                Matthias

                Comment


                • #9
                  Hello,

                  Please check the following registry entry:
                  HKLM \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Run \ AxiMonitor

                  My bets is that the data is:
                  "C:\Program Files\Axigen Mail Server\\bin\AxiMonitor.exe"

                  Please change \\bin in\bin (there should be no double '\') and check if after Windows reboots the AxiMonitor is started, triggering starting Axigen as well.

                  HTH,
                  Ioan

                  Comment


                  • #10
                    Hi Ioan,

                    you were correct, this registry entry was set incorrectly, but after restarting Axigen still does NOT start automatically without someone logging in.

                    I'm sorry for being such a pain, but any last guesses?

                    Thanks,

                    Matthias
                    Last edited by MatythiasAussi; 04-17-2017, 01:24 PM.

                    Comment


                    • #11
                      Originally posted by indreias View Post
                      Please check the following registry entry:
                      HKLM \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Run \ AxiMonitor
                      Hi Ioan,

                      I think this registry key only works when someone logs in, not when the server starts...
                      What can I do?

                      Thanks,

                      Matthias

                      Comment


                      • #12
                        Originally posted by indreias View Post
                        Hello,

                        Please check the following registry entry:
                        HKLM \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Run \ AxiMonitor
                        Hi Ioan,

                        I have just upgraded to 10.1.4 so login via Chrome works again.
                        The issue still persists.
                        Is there any plan to drop the memory requirements again?
                        At the moment Axigen does not start when my server re-starts unexpected. I need to log in first for it to start... :-(

                        Thanks,

                        Matthias

                        Comment


                        • #13
                          Hello,

                          Have you tried (again) to install the service?
                          Code:
                          C:\Program Files\Axigen Mail Server\bin>axigen --install
                          HTH,
                          Ioan

                          Comment


                          • #14
                            Originally posted by indreias View Post
                            Hello,

                            Have you tried (again) to install the service?
                            Code:
                            C:\Program Files\Axigen Mail Server\bin>axigen --install
                            HTH,
                            Ioan
                            Hi Ioan,

                            yes, same result:
                            Code:
                            C:\Program Files\Axigen Mail Server\bin>axigen.exe --install
                            Not enough available memory: 243MB (min=512MB required)
                            :-(

                            Comment


                            • #15
                              Hello,

                              Please try the following steps to be performed during the next available maintenance window:

                              1. Reboot your Windows instance
                              2. Login and, before starting manually the Axigen server please retry to install the service

                              If this operation still fails you definitely have to check why your Windows instance does not have at least 512 MB free memory required for Axigen.

                              HTH,
                              Ioan

                              Comment

                              Working...
                              X