Announcement

Collapse
No announcement yet.

DKIM Signing Not Working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • vicjalan
    started a topic DKIM Signing Not Working

    DKIM Signing Not Working

    Hi,

    I've running the free version of Axigen for a home setup and I can't seem to get DKIM signing to work. I've read all of the other posts regarding this issue and I believe I've covered everything.

    See attached image for the "Acceptance & Routing" settings.

    In the Queue error logs I get:
    Code:
     2018-06-04 04:45:19 +0000 02 mail PROCESSING:001AB7A5: DomainKeys signing aborted because the key or selector does not exist
    My SMTPFilters.script looks correct:
    Code:
    method DomainSign-gkscs_com {
            if (
                    allOf (
                            isCase (mailFromDomain, "gkscs.com"),
                            not (
                                    is (authUser, "")
                            )
                    )
            ) {
                    set (DKIMSignerSelector, "axigen");
                    set (DKIMSignerSelector, "axigen");
                    set (DKSignerKey, "dkim.privkey.gkscs_com.pem");
                    set (DKIMSignerKey, "dkim.privkey.gkscs_com.pem");
                    call (signDomainKeys);
                    call (signDKIM);
            }
    }
    From the mail server I execute:

    Code:
    root@mail:/var/opt/axigen/filters# dig +short txt axigen._domainkey.gkscs.com @8.8.8.8
    "k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCrSqmRIn2rMJr29gwKIP8xz6gkgnwmysbUmi9kNq8fAdGlYFKe+SbTbDB2YNOxYO+y+8jnr6i6/gWTR1nrWfQ7bkrJllaS82zourZsQsYuROq/HlLHiix83n9VviE3iO3twXGQzn/QhWdYfoUNQeV0xN7SOxcSLKHveG6s4WukywIDAQAB"
    I've tested the following as well:

    Code:
    root@mail:/var/opt/axigen/filters# telnet 0 7000
    Trying 0.0.0.0...
    Connected to 0.
    Escape character is '^]'.
    Welcome to AXIGEN's Command Line Interface
    You must login first. For a list of available commands, type HELP
    <login> admin
    -ERR: Syntax error
    <login> user admin
    <password> l00z3r)@
    For a list of available commands, type HELP
    +OK: Authentication successful
    <#> config server
    +OK: command successful
    <server#> config dnr
    +OK: command successful
    <server-dnr#> QUERY TXT axigen._domainkey.gkscs.com
    
    TXT data
    -----------------------------------------------------------------
    k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCrSqmRIn2rMJr29gwKIP8xz6gkgnwmysbUmi9kNq8fAdGlYFKe+SbTbDB2YNOxYO+y+8jnr6i6/gWTR1nrWfQ7bkrJllaS82zourZsQsYuROq/HlLHiix83n9VviE3iO3twXGQzn/QhWdYfoUNQeV0xN7SOxcSLKHveG6s4WukywIDAQAB
    +OK: command successful
    Permissions on my certs look fine:

    Code:
    root@mail:/var/opt/axigen# ls -l dkim.*
    -rw------- 1 axigen axigen 887 Jun  2 05:28 dkim.privkey.gkscs_com.pem
    -rw------- 1 axigen axigen 272 Jun  2 05:28 dkim.pubkey.gkscs_com.pem
    I'm not sure what else to try or why this is failing. Can anyone point me to something else I may be missing?

    Thanks,

    Victor

  • indreias
    replied
    Hello Victor,

    All seems fine - could you redone your tests but with the log level set for Processing service to Protocol Communication?

    HTH,
    Ioan

    Leave a comment:

Working...
X

This is the legacy Axigen forum, which is no longer active.

To create new topics & posts, please visit the new Axigen community.

Axigen Community