Announcement

Collapse
No announcement yet.

SPF & DKIM not signed in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SPF & DKIM not signed in

    i am using linux os Centos and using axigen free version 10.2.
    i have configured my domain as per the documentation suggested by axigen.
    my domain is hosted on route53 where there is a bug that u can not enter key without splitting it into multiple parts or min 2 parts due to key length.
    i am able to receive email but its showing below mention details in email header,

    X-AXIGEN-SPF-Result: Failed X-AXIGEN-DK-Result: No records DomainKey-Status: no signature X-AXIGEN-DKIM-Result: No records DKIM-Status: no signature please suggest how to resolve it

    #2
    In order to further assist you, please tell everybody what is the documentation that you followed, how does the DNS records look like now and what configurations did you make on Axigen?

    Comment


      #3
      domain : zorg.com.au
      document followed : https://www.axigen.com/documentation...dmarc-p3277033
      DKIM Record :
      [root@localhost filters]# dig +short txt zorg._domainkey.zorg.com.au @8.8.8.8
      "k=rsa\; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAt4dt w9alUS7HbPA/rry9mw741ERqrMtpSbb5QBNHMiMFpPIlbWygznimpr7HbAkg8K TIfer9UWHb7MQzYm3FoYuUVbxCmh5e1IA4EcjkgLs4W8y97dLa BK8s1xZoMxCpsFYn4Nm74ea2SYjhIFL85GRoPCvKZUhiORw2ct vz1GZ0lS3TExGeOdbuWTmX/" "mBjTjoE5vmOOgYCacXLqlRQwb0YZKLZN2oWBC1/HaoZGpcYjonKWVfGCBgB1RnooRJ3RlzbkiarGDAINqVY9XfJVO ME8j5WJuy5UiXNwohRzol9JHL/tSdHhiAzJJ4cQV0DNO8xvMYXOMGYJ1wIDAQAB"

      if anything else need please let me know, thanks for your response.
      Attached Files

      Comment


        #4
        Hello,

        We've checked your DNS records (here and here) and it seems that something is wrong with the string you are using for specifying the public key.

        Assuming that you have generated your public key in dkim.pubkey.zorg.com.au.pem please provide the output of the following command:
        cat dkim.pubkey.zorg.com.au.pem

        so we could double check if your DNS record is missing any character(s).

        HTH,
        Ioan

        Comment


          #5
          Here it is, it looks differerent bcoz my dns is hosted on route53 and if m trying to update complete key in dns its saying length is too long so i followed a link to update DNS for dkim key in route 53 i.e. https://serverfault.com/questions/76...th-is-too-long

          -----BEGIN PUBLIC KEY-----
          MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAt4dtw9 alUS7+HbPA/rry
          9mw741ERqrMtpSbb+5QBNHMiMFpPIlbWygznim+pr7HbAkg8KT Ifer9UWHb7MQzY
          m3FoYuUVbxCmh5e1IA4EcjkgLs4W8y97dLaBK8s1xZoMxCpsFY n4Nm74ea+2SYjh
          IFL85GRoPCvKZUhiOR+w2ctvz1GZ0lS3TExGeOdbuWTmX/mBjTjoE5vmOOg+YCac
          XLqlRQwb0YZKLZN2oWBC1/Ha+oZGpcYjonKWVfGCBgB1RnooRJ3RlzbkiarGDAIN
          qVY9XfJVOME8j5WJuy5UiXNwohRzol9JHL/tSdHhiAzJJ4cQV0DNO8xvMYXOMGYJ
          1wIDAQAB
          -----END PUBLIC KEY-----

          Comment


            #6
            Thank you for your response.

            Based on your public key, the correct DNS record should be similar with:

            mail._domainkey IN TXT ( "k=rsa; p="MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAt4d tw9 alUS7+HbPA/rry"
            "9mw741ERqrMtpSbb+5QBNHMiMFpPIlbWygznim+pr7HbAkg8K T Ifer9UWHb7MQzY"
            "m3FoYuUVbxCmh5e1IA4EcjkgLs4W8y97dLaBK8s1xZoMxCpsF Y n4Nm74ea+2SYjh"
            "IFL85GRoPCvKZUhiOR+w2ctvz1GZ0lS3TExGeOdbuWTmX/mBjTjoE5vmOOg+YCac"
            "XLqlRQwb0YZKLZN2oWBC1/Ha+oZGpcYjonKWVfGCBgB1RnooRJ3RlzbkiarGDAIN"
            "qVY9XfJVOME8j5WJuy5UiXNwohRzol9JHL/tSdHhiAzJJ4cQV0DNO8xvMYXOMGYJ"
            "1wIDAQAB"


            Please keep us updated in this matter.
            Thank you.

            Comment


              #7
              Hello!
              Use OS MS Windows server 2016
              I see a problem with the DKIM signature, what could be wrong? I use 1 domain.
              The private key is in the directory C:\Axigen Mail Server\

              Attached Files

              Comment


                #8
                Hello,

                Please share your smtpFilters.script (available in the filters folder) so we could see where the key is expected to be located.

                BR,
                Ioan

                Comment


                  #9
                  Here is the file smtpFilters.script, changed the file type to .txt
                  Attached Files

                  Comment


                    #10
                    Hello,

                    First of all the condition selection for rule 'dkmi-sign' should be set to 'ALL of the conditions below' (and not ANY).
                    Second we see that you have 2 rules:
                    * dkmi-sign that is referring to the key file mail_centrrazvitie_kz.pem (that should be present in Axigen working directory - default on Windows to C:\Axigen Mail Server\)
                    * DomainSign-centrrazvitie_kz that is reffering to the key file C:\pmta\mail.centrrazvitie.kz.txt

                    Now - could you let us know which rule are you testing with?

                    I could only suppose that you are testing with dkmi-sign so please double check if in the pem file you have the private key for signing the messages OR the private key and the certificate to be used for SSL connections (that are intended for secure listeners, like https).

                    BR,
                    Ioan

                    Comment


                      #11
                      Hi,
                      I am also having similar "DKIM signing" problem, Axigfen 10.2.2.52, Windows x64 (server 2016).
                      DKIM public (DNS) checks out. https://www.agari.com/insights/tools...name=mig21.xyz
                      Log:
                      2019-03-13 12:12:10 +1100 08 Hades PROCESSING:00371C32: Start filter onProcessing event
                      2019-03-13 12:12:10 +1100 02 Hades PROCESSING:00371C32: Error reading key file
                      2019-03-13 12:12:10 +1100 02 Hades PROCESSING:00371C32: Error executing instruction
                      2019-03-13 12:12:10 +1100 02 Hades PROCESSING:00371C32: Error executing instruction
                      2019-03-13 12:12:10 +1100 02 Hades PROCESSING:00371C32: [onProcessing] Errors executing onProcessing event
                      2019-03-13 12:12:10 +1100 08 Hades PROCESSING:00371C32: Finished filtering mail object 371C32 with filter: onProcessing event
                      2019-03-13 12:12:10 +1100 08 Hades PROCESSING:00371C32: Set recipient <nenad@itpartners.com.au> state to PROCESSING ERROR
                      2019-03-13 12:12:10 +1100 08 Hades PROCESSING:00371C32: Set mail state to PROCESSING ERROR
                      2019-03-13 12:12:10 +1100 08 Hades PROCESSING:00371C32: Processing finished

                      Please see attached smtpfilters.txt
                      Thanks in advance.
                      Nenad
                      Attached Files

                      Comment


                        #12
                        Hello,

                        Please share your smtpFilters.script file (from filters folder) and the logs for a new the test.

                        Before running the test please set the log level for PROCESSING service to Protocol Communication.

                        From the logs you have shared till now all I could say is that there is an "Error reading key file".

                        HTH,
                        Ioan

                        Comment

                        Working...
                        X

                        This is the legacy Axigen forum, which is no longer active.

                        To create new topics & posts, please visit the new Axigen community.

                        Axigen Community