Axigen Community Forum

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

ftp backup crashes axigen service

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ftp backup crashes axigen service

    I am trying to use the ftp backup. Last night, I started a backup of the domains folder. It did not complete.

    Upon restarting the process and requeuing the incomplete folders, it ran for a while, then disconnected and refused to reconnect.

    I had to restart the axigen service, which restored service.

    How can I set it so i can backup trhe domains folder without crashing axigen?

    we are running 7.5 on ubuntu.

    Thank you

    #2
    Hello,

    Please post an archive containing the system mail log, available at:

    /var/log/mail or mail.log

    covering the time period when this behaviour occurred.

    Regards,
    Paul

    Comment


      #3
      Hi,

      I looked through the logs, and I found the places where I had to restart the service. I can attach the whole log file if needed.

      Thank you,

      Kevin Farley

      Comment


        #4
        Here is the portion of the relevant log

        Comment


          #5
          Hello,

          Please see below relevant line extracted from the log file that you have sent to us:

          Jan 4 10:15:06 apollo Axigen[29653]: WARNING: Memory usage reached error level

          It seems that Axigen restarted because of high memory consumption.

          As a possible solution please do the following:

          1. - make sure that you don't have tar enabled.

          Webadmin -> Back-up and restore -> FTP Back-up and Restore -> Message Packaging -> disable "Use the TAR format to pack messages" -> Save Configuration

          After that you must restart the FTP Back-up and Restore service from Webadmin -> Services -> Services Management.

          2. You can configure Axigen Mail Server to use an allocated quota of memory, and make sure that this quota is smaller than remaining free memory after you start the OS where Axigen Mail Server is installed.

          In order to allocate a quota of memory for the Axigen please do the following:

          - stop the AXIGEN service

          - edit the /etc/default/axigen file and add the following line
          at the bottom of the file:

          AXIGEN_DAEMON_OPT="-m 1024"

          - save the file

          - start the AXIGEN service

          Note: Assuming that you have 2048 MB of ram and your OS consumes approx. 900 MB we have allocated 1024 MB to Axigen. Configure the above according to your resources.

          Comment


            #6
            Hello,

            I am running Axigen 8.1 on CentOS 6. How can I edit "AXIGEN_DAEMON_OPT="-m 1024"" ?

            Thanks

            Comment


              #7
              Hello,

              The config file for RPM based systems is /etc/sysconfig/axigen

              Now, before configuring Axigen to use maximum 1G please double check how much memory your system have.

              For your particular case I'll recommend first to add, at the end of that file, the following line:
              Code:
              export MALLOC_ARENA_MAX=4
              and restart Axigen

              HTH,
              Ioan

              Comment

              Working...
              X