• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

550 Sender domain <> has no DNS MX entry

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 550 Sender domain <> has no DNS MX entry

    Hello to all routing rule setup experts!

    I would like to setup a routing rule (I assume that's what's needed) on the mail server to unrestrict local mail delivery. In other words, my server has IP 192.168.50.50 and another NAS has 192.168.50.60. Currently, when the NAS wants to send a status email alert, it get's an error that says:
    550 Sender domain <192.168.0.60> has no DNS MX entry.

    I have checked the "Allow local delivery" option under "Allow / Disallow local delivery" in the "Acceptance Basic Settings."

    My thinking was that the "wizard_generated_relay" rule would work. Also, I tried to add the action SMTP accept, but that did not help either.

    How can I setup a rule that will not restrict the NAS in any way shape or form to deliver emails to the server?
    Thank you for all of your help!
    Wolfgang

  • #2
    Hello,

    This error is caused by the fact that your NAS server tries to send email using '192.168.0.60' as sender domain, while you have enabled the 'Reject message if originator's domain has no MX entry' option under 'Security & Filtering' -> 'Additional AntiSpam Methods'.

    In order to correct this problem, you should either configure your NAS to send emails from a valid domain (that has a MX entry), either disable the mentioned option.

    Best regards,
    Adrian

    Comment


    • #3
      Safe IPs / IP Ranges

      Originally posted by adi View Post
      Hello,

      This error is caused by the fact that your NAS server tries to send email using '192.168.0.60' as sender domain, while you have enabled the 'Reject message if originator's domain has no MX entry' option under 'Security & Filtering' -> 'Additional AntiSpam Methods'.

      In order to correct this problem, you should either configure your NAS to send emails from a valid domain (that has a MX entry), either disable the mentioned option.

      Best regards,
      I have a pretty 'old' personal NAS (Linksys NSLU2) and there is no way to reconfigure the mail settings other than specifying an email address and activating/deactivating the feature.

      In regards to the Axigen mail server setting, I have found the 'DNSBL (DNS BlackList)' setting earlier under 'Additional AntiSpam Methods '.
      First, I think that the UI of the admin pages should be modified slightly to accommodate 'Safe IPs / IP Ranges ' settings under a separate heading, which IMHO should be called 'WhiteList', since it seems to be just that. If somebody has the BlackList settings collapsed, nobody would ever guess nor find the WhiteList as part of the BlackList settings.
      Second, and this seems to be a tricky issue but sort of falls under the same guidelines as it is with general mail filter rules: If somebody defines a 'WhiteList' IP address, the question is if you keep checking more rules or if you exit at that point? - Currently Axigen mail server seems making a decision that a WhiteList specification is not good enough to permit sending mails. My assumption is that if I define an IP address such as 192.168.50.10 as a WhiteList IP, then the mail server should accept sending mails from that IP address, no matter what. Otherwise, why have a WhiteList - or in Axigen terms, an exception for the BlackList? Turing off 'MX entry' checking settings to truly realize a WhiteList may not be the best solution.

      Any thoughts on that?
      Is there an option (through manually modifying some filters perhaps) to implement MX entry settings taking the (new?) WhiteList into consideration? - Possibly something to consider for further development of the Axigen mail server.

      Bottom line: THANK YOU for your response and insight!

      Comment


      • #4
        Hello again,

        The "Safe IPs / IP Ranges" option only refers to the DNSBL checks. The whitelist will include all of the options in a future version of the product and has already been planned.

        Unfortunately, at this time there is no way to escape this behavior and the DNS checks that interfere with the mail delivery should be disabled.

        If you wish to use them, you need to contact your ISP or domain registrar and ask them to provide you with a correct reverse DNS entry (PTR record) for your IP / server.

        Thank you.
        Ciprian NEGRILA,
        Technical Consultant, AXIGEN

        Comment


        • #5
          This is a fairly old post, IMHO, and apparently it has not been resolved yet? 9 years ago! Inquiring minds want to know why, I just ran into the same snag and could really use the ability to whitelist a private IP address that has it's own MTA.... AXIGEN Mail-Server 10.0.0 (Linux/x64).

          Comment


          • #6
            Hello,

            As you have noticed nothing was changed on this subject and my guess is that the most probable reason should be that it were not on the priority list of the dev team.

            Could you share your current setup (for example smtpFilters.script) and the SMTP-IN logs (preferable with the log level set to Protocol Communication) for a session that get rejected by Axigen?

            BR,
            Ioan

            Comment

            Working...
            X