Axigen Community Forum

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

How to completely deactivate Commtouch and Spamassassin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How to completely deactivate Commtouch and Spamassassin

    Hi,
    we are still using Axigen 8.1.0 as an internal mailserver in one of our branch offices. The box will not be updated to version X, because the internal structure will change very soon and this box isn't needed anymore, then.
    For the box doesn't need any spam/av-services i wanted to completely de-activate spamd and commtouch, which are seeming to be active, although the license expired and the services are disabled in the WebAdmin Interface (?).
    I can still see spamd active in processes and commtouch obviousely contacts different commtouch servers - i can see the traffic in our firewall.

    Question: (How) Can i completely deactivate spamd and commtouch?

    I've tried removing both service names ("spamd" + "commtouch") from /etc/init.d/axigenfilters ==> DAEMONS = "..." variable. But that doesn't do the trick, seemingly (see screenshots). On starting ./axigenfilters restart there are error messages.
    How would i do it right?

    <blockquote class="imgur-embed-pub" lang="en" data-id="a/0ls55"><a href="//imgur.com/0ls55"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>

    #2
    Hello,

    Please stop and disable axigenfilters service as its only role is to start any 3rd party daemons needed for AV / AS filtering.

    This could be achieved on RHEL based Linux distributions by running the following commands:
    Code:
    service axigenfilters stop
    chkconfig axigenfilters off
    HTH,
    Ioan

    Comment


      #3
      Hi Ioan,

      that worked like a charm. The services are disabled now. Thanks a lot!

      For all those using Ubuntu (we use 14 LTS on that box), use:

      Code:
      service axigenfilters stop
      to stop the services - like described above - and

      Code:
      update-rc.d axigenfilters disable
      to disable them in startup scripts; or force to completely remove the services from the startup scripts like this (be careful!):

      Code:
      update-rc.d -f axigenfilters remove

      Comment

      Working...
      X