• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Could not connect to built in external clamav

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Could not connect to built in external clamav

    Hi i have installed clamav using the following on debian 9
    apt-get install clamav-base clamav-daemon clamav-docs clamav gpasswd -a clamav axigen /etc/init.d/clamav-daemon restart Axigen still does not recognize the service
    ClamAV
    Built-in External
    Could not connect
    Disabled
    ClamAV-local
    User External
    Disabled ENABLE
    SpamAssassin
    Built-in External
    Available
    Enabled
    The following is the output from /etc/clamav/clamd.conf #Automatically Generated by clamav-daemon postinst #To reconfigure clamd run #dpkg-reconfigure clamav-daemon #Please read /usr/share/doc/clamav-daemon/README.Debian.gz for details LocalSocket /var/run/clamav/clamd.ctl FixStaleSocket true LocalSocketGroup clamav LocalSocketMode 666 # TemporaryDirectory is not set to its default /tmp here to make overriding # the default with environment variables TMPDIR/TMP/TEMP possible User axigen ScanMail true ScanArchive true ArchiveBlockEncrypted false MaxDirectoryRecursion 15 FollowDirectorySymlinks false FollowFileSymlinks false ReadTimeout 180 MaxThreads 12 MaxConnectionQueueLength 15 LogSyslog false LogRotate true LogFacility LOG_LOCAL6 LogClean false LogVerbose false PreludeEnable no PreludeAnalyzerName ClamAV DatabaseDirectory /var/lib/clamav OfficialDatabaseOnly false SelfCheck 3600 Foreground false Debug false ScanPE true MaxEmbeddedPE 10M ScanOLE2 true ScanPDF true ScanHTML true MaxHTMLNormalize 10M MaxHTMLNoTags 2M MaxScriptNormalize 5M MaxZipTypeRcg 1M ScanSWF true DetectBrokenExecutables false ExitOnOOM false LeaveTemporaryFiles false AlgorithmicDetection true ScanELF true IdleTimeout 30 CrossFilesystems true PhishingSignatures true PhishingScanURLs true PhishingAlwaysBlockSSLMismatch false PhishingAlwaysBlockCloak false PartitionIntersection false DetectPUA false ScanPartialMessages false HeuristicScanPrecedence false StructuredDataDetection false CommandReadTimeout 5 SendBufTimeout 200 MaxQueue 100 ExtendedDetectionInfo true OLE2BlockMacros false ScanOnAccess false AllowAllMatchScan true ForceToDisk false DisableCertCheck false DisableCache false MaxScanSize 100M MaxFileSize 25M MaxRecursion 16 MaxFiles 10000 MaxPartitions 50 MaxIconsPE 100 PCREMatchLimit 10000 PCRERecMatchLimit 5000 PCREMaxFileSize 25M ScanXMLDOCS true ScanHWP3 true MaxRecHWP3 16 StreamMaxLength 25M LogFile /var/log/clamav/clamav.log LogTime true LogFileUnlock false LogFileMaxSize 0 Bytecode true BytecodeSecurity TrustSigned BytecodeTimeout 60000 root@box:~# ps -ef |grep clam axigen 617 1 0 16:08 ? 00:00:00 /usr/bin/freshclam -d --foregroe root 1674 1096 0 16:48 ttyS0 00:00:00 grep clam Output of Clamav.log Sun Aug 5 16:53:16 2018 -> +++ Started at Sun Aug 5 16:53:16 2018 Sun Aug 5 16:53:16 2018 -> Received 0 file descriptor(s) from systemd. Sun Aug 5 16:53:16 2018 -> clamd daemon 0.100.1 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64) Sun Aug 5 16:53:16 2018 -> Running as user axigen (UID 220, GID 220) Sun Aug 5 16:53:16 2018 -> Log file size limited to 4294967295 bytes. Sun Aug 5 16:53:16 2018 -> Reading databases from /var/lib/clamav Sun Aug 5 16:53:16 2018 -> Not loading PUA signatures. Sun Aug 5 16:53:16 2018 -> Bytecode: Security mode set to "TrustSigned". Sun Aug 5 16:53:44 2018 -> Loaded 6598772 signatures. Sun Aug 5 16:53:47 2018 -> LOCAL: Removing stale socket file /var/run/clamav/clamd.ctl Sun Aug 5 16:53:47 2018 -> LOCAL: Unix socket file /var/run/clamav/clamd.ctl Sun Aug 5 16:53:47 2018 -> LOCAL: Setting connection queue length to 15 Sun Aug 5 16:53:47 2018 -> ERROR: Failed to change socket ownership to group clamav

  • #2
    Please repost your question so it could be easy to read it

    Comment


    • #3
      After doing many tweaks . i got this to work , thanks a lot

      Comment

      Working...
      X