No announcement yet.

Problems with Axigen + ClamAV

  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with Axigen + ClamAV

    Greetings Community,

    I have been trying to get Axigen (v10.2.1) working with ClamAV (v0.100.1.3). I have followed the guide posted on these forums here (See post #13 for Centos 7):

    ClamAV is properly setup on my mailserver, and it updates properly with freshclam. It scans successfully and identifies viruses from the command line. etc. However, when I go into Axigen and enable it, it causes all mail delivery to stop, the logs show this error message:

    PROCESSING:00207CF6: Error connecting to socket filter: ClamAV(/var/run/clamav/clamd.ctl) reason: No such file or directory

    Can anyone point me in the right direction? How do I troubleshoot this?

    ps : can someone explain why I have two ClamAVs listed in the Axigen GUI: I have ClamAV (Type=Built-in External), then I have ClamAV-local (type: User External).


    Please know that we have tested the ClamAV installation on CentOS 7 by using the steps from the guide available at the link:

    To make clamd listen on port 3310 we uncommented the lines below:

    TCPSocket 3310

    in the configuration file.

    After the service started, we added the clamscan system user to the axigen system group so that clamd can access the queue files to scan them then restarted the service. At this point ClamAV was displayed as available in Webadmin -> Security & Filtering -> AntiVirus & AntiSpam -> Supported Applications. Then we enabled it, sent a test message and confirmed that it was scanned.

    Please find attached to this message the file clamav_centos7.txt containing the commands used. Our suggestion is to try the same steps.

    Regarding the two ClamAV filters listed in the Webadmin interface, the difference between them is how Axigen tries to communicate with ClamAV, respectively one filter uses a local socket while the other uses a TCP socket. After performing the steps described above you should enable only the "ClamAV" filter, not "ClamAV-local"

    Thank you.
    Attached Files



    This is the legacy Axigen forum, which is no longer active.

    To create new topics & posts, please visit the new Axigen community.

    Axigen Community