Axigen Community Forum

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

SSL listener accepts the self assigned cert for WebAdmin but not WebMail?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    SSL listener accepts the self assigned cert for WebAdmin but not WebMail?

    So I have my server set up and it is working well. Managed to proxy via Nginx the WebMail interface but only non-ssl.

    In the WebAdmin I have managed to set up the SSL listener on port 81.
    But if I try the same SSL cert on WM it fails.

    Regenerated using "/etc/init.d/axigen init" but the same thing happens.
    Also tried my own cert from Lets Encrypt but the same thing happens.

    The error I get is "Invalid path to certificate file or invalid certificate file!".

    What am I doing wrong here?


    #2
    Try to use the documentation listed here for using Let's Encrypt certs with Axigen:
    https://www.axigen.com/documentation...port-p10649619

    Comment


      #3
      Originally posted by bogdanmoldovan View Post
      Try to use the documentation listed here for using Let's Encrypt certs with Axigen:
      https://www.axigen.com/documentation...port-p10649619
      I am using Nginx to proxy the Axigen web interfaces as my LAMP web server runs default ports.
      Presuming to save a lot of headache I should just dedicate an IP to Axigen?

      Comment


        #4
        I think that would be easiest.
        Also make sure the DNS records are pointed correctly.

        Comment


          #5
          Okay I got the HTTPS working now, thanks for that link. When it comes to SMTP and IMAP is this the same certificates?

          I put them in anyway as the SSL certs but I am errors from ssl-tools.com mail server test which is saying that my cert is self assigned by Axigen and is actualy the server's hostname url not my mail.tld domain.

          Any ideas? Or should I send over an email.

          Comment


            #6
            Hello,

            Yes, you could use the same certificate for SMTP and IMAP (or any other service for which you have activated an SSL listener).

            I suspect that you have used a test tool that is supporting only HTTPS and this is why my advice is to use one from the following list:If there are still problems please share the Axigen configuration file (axigen.cfg) and the hostname + port you have used in your tests.

            HTH,
            Ioan

            Comment


              #7
              Having an issue with the SSL being made.
              The common name is set to "mail".

              This was originally the hostname but was changed.
              Let's Encrypt does not look to be picking up this change so keeps generating with "mail" as the common name. Resulting in bad cert.

              Comment


                #8
                Have you tried to recreate the SSL cert with the new virtual hostname?

                Comment

                Working...
                X