Axigen Community Forum

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

on RPOP. pls help.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    on RPOP. pls help.

    Hello,

    I am not sure how RPOP is supposed to work.

    What I need is to donwload a large archive (almost 10.000 posts) from an account of mine (and delete the archive from the remote server).

    I created a >myself< account under the localhost domain, and activated RPOP at the server, domain and account levels.

    As suggested within another thread, I checked things by telnet, and got the following output:
    ------------------------------------------
    telnet mbox.<domain>.it 110
    Trying <ip number>...
    Connected to mbox.<domain>.it.
    Escape character is '^]'.
    +OK POP3 Ready <server>
    user <user>@<domain>.it
    +OK USER <user>@<domain>.it set
    pass <password>
    +OK You are so in
    stat
    +OK 10280 94232547 <<<< too many?
    uidl 1
    +OK 1 1183015752.89037.<server>.it,S=5488 <<<< ???
    quit
    +OK
    Connection closed by foreign host.
    -------------------------------------

    my axigen account setting is:
    Idx Host Username Options
    1 mbox.<domain>.it:110 <user>@<domain>.it

    BUT, axigen is not retrieving anything.
    Which issue could be? Any advise is welcome.

    thanks a lot

    mario

    #2
    Hello,

    For further investigation on this issue, please set the maximum log level for the RPOP component by enabling all of the 'logLevel' checkboxes under the 'RPOP' context in Webadmin. Save the changes by using the 'Update', 'Commit' and 'Save config' buttons, then wait for the Axigen server to attempt again downloading the messages (this takes up to the 'Retrieval interval' you defined in Webmail for your RPOP connection).

    After that, please post here (or send us attached to support[at]axigen[dot]com) the resulting Axigen log file, /var/opt/axigen/log/everything.txt.

    Best regards,
    Adrian

    Comment


      #3
      help!!!!

      Hi

      thank a lot for the reply.

      Originally posted by adi View Post
      Hello,

      For further investigation on this issue, please set the maximum log level for the RPOP component by enabling all of the 'logLevel' checkboxes under the 'RPOP' context in Webadmin.
      you mean checkbox 16?

      Originally posted by adi View Post
      Save the changes by using the 'Update', 'Commit' and 'Save config' buttons, then wait for the Axigen server to attempt again downloading the messages (this takes up to the 'Retrieval interval' you defined in Webmail for your RPOP connection).
      nothing happen

      Let me describe what works and what doesn't.

      1. I installed Axigen on my laptop machine, under Fedora7. I disabled firewall and SElinux (at least I think so). I create a myself account under the localhost domain. Both interfaces at localhost:9000 and localhost:8000 work ok.
      I am using the Evolution mail client. If I set Evolution preferences as to receive mail from localhost:110 and sending mail to localhost:25, Evolution and Axigen communicate quite well. (I need to enable listeners for smtp at 127.0.0.:25, for pop3 at 127.0.0.1:110)

      2. If I try to connect to the laptop from another machine within my home LAN (so say laptop is at 192.168.0.3, other machine is at 192.168.0.2), I can use the webmail by browsing at 192.168.0.3:8000. However, it doesn't seem that I may access the webadmin, at 192.168.0.3:9000 (why?). Also, there no way to use a mail client on the other machine to retrieve and/or send mails. Indeed, to telnet the first machine from the second machine at port 110 return a >no connection possible< msg. Do you need more listeners? or what?
      (maybe is not a axigen issue, but any advise you may have is welcome anyway)

      3. Main issue. About the RPOP connection for my myself account, nothing happen. I looked at the log file but there is nothing about my remote connection.

      looking forward your help
      my best
      mario

      ps I am sending the log file, which is too big as an attachment, to support[at]axigen[dot]com)

      Comment


        #4
        In order to access any AXIGEN service from your network, you'll have to change the listener for that service to listen on your internal network IP address, not 127.0.0.1 which accepts only local connections (from your laptop).
        Same if you have a public IP, you can set that in the service's listener to accept connections from outside your internal network.
        Or set listener to "0.0.0.0" to bind for all above.

        As for the RPOP issue, check that RPOP service is active for each level (server, domain and account). This is done from Webadmin by clicking on the RPOP check-box from each context:
        - 'Server' context, check 'RPOP'; Update, Commit and Save config;
        - 'Domain' context, 'Edit' your domain, check 'RPOP'; Update, Commit and Save config;
        - 'Accounts' context, 'View' your domain, 'Edit' your account, check 'RPOP'; Update, Commit and Save config.
        Now try again. Define your RPOP connection and wait for it

        Regards,

        Comment


          #5
          Originally posted by kronos View Post
          In order to access any AXIGEN service from your network, you'll have to change the listener for that service to listen on your internal network IP address, not 127.0.0.1 which accepts only local connections (from your laptop).
          Same if you have a public IP, you can set that in the service's listener to accept connections from outside your internal network.
          Or set listener to "0.0.0.0" to bind for all above.
          Yes, of course. It seems it works (I am writing from within a public library LAN and telnet 110 now works.) And yes, it works for webmail (I see it from any other machine in the library)

          Originally posted by kronos View Post
          As for the RPOP issue, check that RPOP service is active for each level (server, domain and account). This is done from Webadmin by clicking on the RPOP check-box from each context:
          - 'Server' context, check 'RPOP'; Update, Commit and Save config;
          - 'Domain' context, 'Edit' your domain, check 'RPOP'; Update, Commit and Save config;
          - 'Accounts' context, 'View' your domain, 'Edit' your account, check 'RPOP'; Update, Commit and Save config.
          Now try again. Define your RPOP connection and wait for it

          Regards,
          all done, but it doesn't work.
          How do I check that things have been written into the right configuration files? I see axigen.cfg, but it seems to be just for the server level, isn't it?

          thks mario
          Last edited by mario; September 15th, 2007, 09:59 AM. Reason: better check

          Comment


            #6
            Yes, only the setting for server level is stored in axigen.cfg. The domain and account level ones are stored within the domains storage.

            From the message you've sent at support/at/axigen/dot/com:
            09-15 09:54:09 +0200 02 localhost RPOP:0000000A: rpop connection ended, status: 5;Cannot connect to remote host: Host not found

            Check your settings.

            Regards,

            Comment


              #7
              Originally posted by kronos View Post
              Yes, only the setting for server level is stored in axigen.cfg. The domain and account level ones are stored within the domains storage.

              From the message you've sent at support/at/axigen/dot/com:
              09-15 09:54:09 +0200 02 localhost RPOP:0000000A: rpop connection ended, status: 5;Cannot connect to remote host: Host not found

              Check your settings.

              Regards,
              I have checked.
              See at the log (the same happens every 10 minutes, of course!)
              09-15 11:37:54 +0200 16 localhost RPOP:00000021: << +OK POP3 Ready martin
              09-15 11:37:54 +0200 16 localhost RPOP:00000021: >> USER <user>
              09-15 11:37:54 +0200 16 localhost RPOP:00000021: << +OK USER <user> set
              09-15 11:37:54 +0200 16 localhost RPOP:00000021: >> PASS *****


              09-15 11:38:24 +0200 16 localhost RPOP:00000021: << +OK You are so in
              09-15 11:38:24 +0200 16 localhost RPOP:00000021: >> STAT
              09-15 11:38:24 +0200 16 localhost RPOP:00000021: << +OK 10426 97305768
              09-15 11:38:27 +0200 02 localhost RPOP:00000021: rpop connection ended, status: 16;Authentication failed

              How should I understand it: it seems I get in, look at the stat, and then (?) authentication fails.
              Your advise is welcome

              thks mario
              Last edited by mario; September 15th, 2007, 10:19 AM.

              Comment


                #8
                Try using 'user@domain' for username in the RPOP connection.

                Comment


                  #9
                  Originally posted by kronos View Post
                  Try using 'user@domain' for username in the RPOP connection.
                  I had already tried:
                  09-15 11:27:21 +0200 16 localhost RPOP:0000001E: << +OK POP3 Ready martin
                  09-15 11:27:21 +0200 16 localhost RPOP:0000001E: >> USER <user>@<domain>.it
                  09-15 11:27:21 +0200 16 localhost RPOP:0000001E: << +OK USER <user>@<domain>.it set
                  09-15 11:27:21 +0200 16 localhost RPOP:0000001E: >> PASS *****


                  09-15 11:27:51 +0200 16 localhost RPOP:0000001E: << +OK You are so in
                  09-15 11:27:51 +0200 16 localhost RPOP:0000001E: >> STAT
                  09-15 11:27:51 +0200 16 localhost RPOP:0000001E: << +OK 10426 97305768
                  09-15 11:27:54 +0200 02 localhost RPOP:0000001E: rpop connection ended, status: 16;Authentication failed


                  mario

                  Comment


                    #10
                    Update.

                    Hello

                    some good news and a bad one.
                    First the GOOD new.

                    I tried to fetch mail by fetchmail. It works and it is quite simple.
                    I am sure you know much better than me, but let me tell my story.

                    1. I created a linux user account mario (and >su mario)

                    2. I created a hidden file ./fetchmailrc within the mario dir /home/mario/; chmod 710 it; and wrote the line:
                    >>> poll mbox.<domain>.it protocol pop3 port 110 username "<user>@<domain>.it" password "*******" <<<
                    (where <user> and <domain> are according to my mail account at my ISP)
                    see at http://fetchmail.berlios.de/fetchmail-man.html#40

                    3. I created a axigen account mario@localhost and enabled a smtp-in listener for my LAN IP:25

                    4. I gave the command > fetchmail --fetchlimit 3,


                    and WOW, everything worked: three msg from my account beautifully popped up on the axigen webmail interface. GREAT and very nice.

                    That bad new is that the axigen RPOP service still return:
                    localhost RPOP:0000000E: rpop connection ended, status: 16;Authentication failed.

                    It is a nice day, though a little hot
                    my best
                    mario

                    ps pls let me know any further hint you may have on the RPOP issue. Any other advise you may have is welcome too.

                    Comment


                      #11
                      Hello,

                      Thank you very much for the information provided in your last post. It will prove very valuable to the other users of this forum. Please feel free to share any other hints and useful information.
                      Ciprian NEGRILA,
                      Technical Consultant, AXIGEN

                      Comment


                        #12
                        How do I delete msgs from remote server?

                        Originally posted by ciprian View Post
                        Thank you very much
                        You welcome.
                        An update.

                        Now RPOP works!
                        (I have not an idea why. Maybe I needed just to reboot )

                        I have a new issue:
                        Although I switch to YES for the Delete on retrievals (under Settings -> Existing RPOP Connections), axigen retrieve my msgs from the remote server but it does not delete them. So, it keeps to retrieve the same bunch of mail for ever.
                        UPDATE NOW IT SEEMS IT WORKS (after rebooting)
                        (so, I assume that you fixed the issue discussed at
                        http://www.axigen.com/forum/showthread.php?t=2912)

                        btw: I see that the Info page claims that my (free) license is just for 7 days more:
                        >>You are running AXIGEN Mail-server Version 4.0.2 (Linux/i686)
                        remainingTrialDays 7<<
                        Is it so, even if I use axigen strictly for myself?

                        please, let me play around with your tool
                        thanks mario
                        Last edited by mario; September 30th, 2007, 12:39 PM. Reason: SOLVED

                        Comment


                          #13
                          Hello,

                          Originally posted by mario
                          (so, I assume that you fixed the issue discussed at
                          http://www.axigen.com/forum/showthread.php?t=2912)
                          Yes, the issue from the post you mentioned was fixed.

                          Originally posted by mario
                          >>You are running AXIGEN Mail-server Version 4.0.2 (Linux/i686)
                          remainingTrialDays 7<<
                          You are not using a license key, you are in the 30 days trial period, with 7 days left. To get a free Office Edition (5 mailboxes) license key fill in the form from this link:
                          http://www.axigen.com/mail-server/register.php

                          Originally posted by mario
                          Is it so, even if I use axigen strictly for myself?
                          That's why there's a free Office Edition

                          Regards,

                          Comment

                          Working...
                          X