Docker Update to 10.4 and some issues with TNEF and Spamassassin

I updated from the X3 to X4 Docker successfully save for a few issues and I’m hoping either they’re bugs/issues and can get fixed or maybe I’m just doing something wrong and someone can point out what.

TNEF-
The bin does not start during the container start up, if you manually activate it from /axigen/bin/axigen-tnef -p 8888 &
Then everything runs great, otherwise, failure to connect.

SpamAssassin-
I run in compose and I have a separate container for SpamAssassin, I’d like to simply use the dns name via the local resolver but it appears that Axigen isn’t capable of resolving names for SA URIs?
The name definitely resolves ( can ping from container after adding ping… ) but even the port ends up being blanked out if a name value is in the URI:

E.g.:

        {
            name = "AV:SpamAssassin"
            address = "inet://spamassassin:783"
            protocolFile = "afsl/spamassassin.afsl"
            idleTimeout = 300
            actionOnMatch = pass
            maxConnections = 10
            maxMessageSize = 10240
        } 

ping spamassassin
PING spamassassin (172.30.0.2) 56(84) bytes of data.
64 bytes from mail-spamassassin-1.mail_default (172.30.0.2): icmp_seq=1 ttl=64 time=0.165 ms
64 bytes from mail-spamassassin-1.mail_default (172.30.0.2): icmp_seq=2 ttl=64 time=0.052 ms

However, when we try and check that connection ( or use it, since I know that check has had issues in the past ) we get:

2023-01-07 17:10:45 +0000 02 8f7489f7be3b PROCESSING:000768FF: Filter SpamAssassin Filter(0.0.0.0:0):[ERROR]: Could not connect to filter
2023-01-07 17:10:45 +0000 02 8f7489f7be3b PROCESSING:000768FF: Error connecting to socket filter: SpamAssassin Filter(0.0.0.0:0)

Changing it to the IP URI works just fine:


        {
            name = "AV:SpamAssassin"
            address = "inet://172.30.0.2:783"
            protocolFile = "afsl/spamassassin.afsl"
            idleTimeout = 300
            actionOnMatch = pass
            maxConnections = 10
            maxMessageSize = 10240
        }

2023-01-07 17:12:26 +0000 08 8f7489f7be3b PROCESSING:003C24B3: Filter SpamAssassin Filter(172.30.0.2:783):[PASS]: Spam: False ; 0.2 / 5.0

Is it a bug/known issue or, I’m doing something stupid?
Thanks all, lol

Hello Scott,

First thank you for your reports.

We were able to replicate the Tnef behaviour and also we noticed other issues during the Upgrade from 10.3.x to 10.4.x in Docker deployments and we will investigate this further.

Regarding your issues please let me know the command used to run the Axigen container and also if is possible attache the Axigen configuration file (/axigen/var/run/axigen.cfg) in order to provide you the changes to resolve the tnef issue.

Regards,
Florin

Hello Florin,

That’s excellent, HTH.

I run from compose, here is my compose:

version: '3.1'

services:
  spamassassin:
    image: tiredofit/spamassassin
    restart: always
    volumes:
      - "./logs:/logs"
      - "./config:/config"
      - "./data:/data"
    ports:
      - "783:783"
  axigen:
    image: axigen/axigen:latest
    restart: always
    depends_on:
      - spamassassin
    volumes:
      - "./axigen:/axigen/var"
    ports:
      - "443:443"
      - "9443:9443"
      - "993:993"
      - "995:995"
      - "25:25"
      - "465:465"
      - "9000:9000"
      - "7000:7000"
      - "80:80"

Attached is my configuration with the domains removed.
axigen.txt (57.7 KB)

Hello,

To resolve the Tnef issue edit your configuration file (axigen.cfg) and at line 1263 change the path for axigen-tnef binary from /opt/axigen/bin/ to /axigen/bin/

Ex:

            {
                name = "axigen-tnef"
                enable = yes
                type = managedCommand
                command = "axigen-tnef"
                requestTimeout = 0
                configParams = (
                    {
                        name = "binDirectory"
                        value = "/axigen/bin/"
                    }
                )
            }

Regarding Spamassassin I will try to reproduce the reported behaviour and come back with an update.

Regards,
Florin