Upgrading my Axigen from to Axigen 10.3.1

I have been using Axigen for quite a while and I have done in place upgrades for ever since. With the new version they have brought out I am getting an error where the service will not start. If i click cancel the installation stops and roll backs. Has anyone had this same issue?


Before upgrading please check the supported operating systems for Axigen 10.3.x in this page: https://www.axigen.com/mail-server/platforms/

On Windows, Axigen X3 runs only on Windows Server 2019/2016 and Windows 10.

What Operating System are you running Axigen there? What windows version is that?


I understand that but the same thing was said of 10.2 and 10.1 and it still worked. What has changed in 10.3?

Hello Gavin,

Have you tried to run the installer with the main “administrator” user?

We have found that in some installations the account used for upgrading Axigen has not enough rights for installing system services.


I am using the network administrator and another thing the file does not have the option to right click on it and say run as administrator

I tried the local administrator account still same error

Limiting version 10.3 to work only for 2016/2019 or 10 is a VERY short-sighted, user-unfriendly solution. A huge amount of 2012r2 is used in the world. For example, only I have ~ 10 axigen servers running on 2012r2. I planned a purchase, but now I will look for another solution. I think I’m not alone. Tell managers and developers about this.

Hello Kotov,

You may stick on 10.2.2 till you switch to a supported OS version - no need to panic.


Hi, I just tried to upgrade as well to the latest version on Windows server 2016 and I had the same problem as you mentioned in the picture. I tried everything, even fresh installation and nothing, still the same error. I tried it as domain admin or local admin and nothing. Then I tried to install on different “clean” server and it worked.
I had similar problem with the older version.
So maybe this can help you, as I use ClamAV and Spamassassin as service, I stopped all these 3 services and then everything worked as it should and upgrade was successful. So maybe try to stop these services, if you have them.