Axigen with SSL Not workring using port 465 and 587


I am using axigen free version and trying to implement ssl when sending email, Configured port 587 and 465 and using an email function in code but its not working.

Articles used for configuration:

Code :

Getting error :

"Syntax error, command unrecognized. The server response was:"

Please suggest what to do


If not already fixed you should set log level to Protocol Communication for SMTP Receiving service and check the SMTP-IN log lines for any hints related to your report.



I am using this script for sending email via powershell.

Send-MailMessage -From ‘’ -To ‘’ -Subject ‘Sending a test’ -Body “This is just a test” -SmtpServer ‘’ -UseSsl -Port 465

Getting this error,
If m doing telnet it showing blank black screen so it looks like its connecting to server but something is missing.

Send-MailMessage : Unable to read data from the transport connection: net_io_connectionclosed.
At D:\PF\Checkemailssl.ps1:1 char:1

  • Send-MailMessage -From ‘’ -To 'khurram.imtiaz@x …
  •   + CategoryInfo          : InvalidOperation: (System.Net.Mail.SmtpClient:SmtpClient) [Send-MailMessage], SmtpExcep
      + FullyQualifiedErrorId : SmtpException,Microsoft.PowerShell.Commands.SendMailMessage

any update on this?
Please review the post and provide solution m using free axigen


Could you please share the screen capture (from WebAdmin) for SSL configuration on Axigen listener configured for port 465 used by your script?


Here it is,


1/ in case the Certificate file contains all needed data there is no need to reffer again into Certificate autorities file

2/ Please tick the DH parameter file and set it to axigen_dh.pem (before this please double check if you have this file into Axigen working dir)

3/ Please set the following Cipher suite: ‘ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH’ as maybe there is an incompatibility at this level with the existing configuration

If this still not solve your issue please check if all is fine with openssl (as telnet is not the appropiate tool to debug SSL connections) like:

$ openssl s_client -connect <your-axigen-server_IPaddress>:465 -crlf

Also, a good ideea is to set log level to Protocol Communication for SMTP Receiving service and share the SMTP-IN log lines geenrated by Axigen when you are trying to connect with your script.



I made the mentioned changes,

Added a Rule as per the community guideline,

But after adding this rule, i am unable to send email with port 25 aswell, disabling this rule can make it working.
With port 465 i used the openssl command you mentioned, pasting the result.


Using the script mentioned above for port 465

Send-MailMessage -From ‘’ -To ‘’ -Subject ‘Sending a test’ -Body “This is just a test” -SmtpServer ‘’ -UseSsl -Port 465

2022-04-05 07:41:27 +0000 08 ip-10-0-100-213 SMTP-OUT:00000020: Relay mail 2F2C9F: unable to connect to Connection timed out
2022-04-05 07:41:27 +0000 08 ip-10-0-100-213 SMTP-OUT:00000020: Relay mail 2F2C9F: no more relays for
2022-04-05 07:41:27 +0000 04 ip-10-0-100-213 SMTP-OUT:00000020: Delivery attempt completed for mail 2F2C9F; 1 recipients remaining; reschedule for delivery
2022-04-05 07:41:27 +0000 08 ip-10-0-100-213 SMTP-OUT:00000020: Set mail state to SEND FAILURE

Nothing in SMTP -IN realated to port 465 bcoz of error.

Hi any update?


Without SMTP-IN logs we could not point you to any hints. I do not see any error on port 465 when using openssl so should double check if:
1/ you have set SMTP Receiving service on Protocol Communication
2/ you have access to the log file where this service is saving the logs (needs to be in Protocol Communication as well)

After that you could compare the SMTP-IN log lines generated for the test with OpenSSL and the log lines generated by your PowerShell script