How to transfer your Axigen installation from a 32 bit to a 64 bit system on Linux

Axigen X is available only for the 64 bit architecture. If you are using a 32 bit Linux system you can use the steps described in this KB article to transfer your existing Axigen installation on a 64 bit Linux system.

Resolution

The steps to transfer the Axigen installation on a new 64 bit Linux server:

  • Install on the new server exactly the same Axigen Mail Server version as the one installed on the old server. For example, if you are currently using Axigen 9.0.2 on a 32 bit Linux system, you will install Axigen 9.0.2 64 bit on the new server. You can find the 64-bit Axigen 9.0.2 download links below:
  • Do dot start the Axigen services on the new server
  • Stop the Axigen services on the old server
  • Copy the Axigen working directory, /var/opt/axigen , from the old server to the new server — NOTE: if you have domain storages located outside of the Axigen working directory, they will need to be copied too.
  • Make sure that on the new server, the Axigen working directory and all the files contained in it are owned by the "axigen" system user. To achieve this, you can issue the following command: chown -R axigen:axigen /var/opt/axigen
  • Start the Axigen services on the new server

Then you can proceed with the upgrade to Axigen X. The Axigen upgrade procedure for Linux platforms is described in our online KB article available at the following URL: http://www.axigen.com/kb/show/283

You should also consider the following precautions when upgrading:

  • If your Webmail interface was customized in any way, you will need to adapt the changes to the new version, after the upgrade.
  • If any of your domain storages resides outside the Axigen working directory (/var/opt/axigen), please also include the respective locations into your backup.
  • Before proceeding with the upgrade, please ensure that your license key's maintenance date parameter (as visible within the "Global Settings" context in Webadmin) allows you to use Axigen X. The date contained by this parameter has to be later than the release date of the version you are upgrading to.
  • If you are using Outlook Connector, this plug in will need to be upgraded too.
Applies to
Releases: Axigen 10.0.x
OS: LinuxFreeBSD